Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1   Report Post  
Old June 24th 15, 01:59 PM
Junior Member
 
First recorded activity by BoatBanter: Jun 2015
Location: Boldon Colliery UK
Posts: 2
Angry Nanni Diesel T4 155

Hope some one can help, my Nanni diesel engine when started appears ok and on running up to 2000 RPM is still ok, however above 2000 rpm the engine starts to emit white smoke and lose power, filters and injectors have been renewed. An interesting fact is if I start engine without sea water cooling to engine for a short time the engine runs ok, even when I run without gb clutched in. I now suspect Charge Air Cooler, any Idea,s

Best Regards
Mick

  #2   Report Post  
Old June 24th 15, 02:38 PM
Junior Member
 
First recorded activity by BoatBanter: Jun 2015
Location: Boldon Colliery UK
Posts: 2
Default Nanni Diesel T4 155

Hi all, I have a motor boat that has a Nanni t4 155 hp engine, the problem is When engine is running up to 2000 RPM every thing appears to be ok, on increasing revs the engine starts to miss and power falls off until I bring it back down to 2000 rpm, I have tested the engine along side with GB clutched out, on raising the rpm the engine starts to miss with a lot of white smoke coming from exhaust.
The fuel filters and injectors have been changed, pipe work checked for tightness, all appears ok.
I have tried the engine for a short time with sea suction closed so that no water passes through charge air cooler, When this is tried the white smoke disappears and engine runs smoothly. Open sea cock and after a short while white smoke returns and engine starts missing.
I realise that I can only run engine a short time without cooling as this will do the jabsco no good
Anyone out there had this problem before

Best Regards
Mick
  #3   Report Post  
Old July 15th 16, 12:16 AM posted to uk.rec.boats.power
external usenet poster
 
First recorded activity by BoatBanter: Mar 2007
Posts: 10
Default Nanni Diesel T4 155

In article , tugdolan
wrote:

Hope some one can help, my Nanni diesel engine when started appears ok
and on running up to 2000 RPM is still ok, however above 2000 rpm the
engine starts to emit white smoke and lose power, filters and injectors
have been renewed.


The date of your post sugests either your machine's clock is out or this
post has been held up for a long time so you may have fixed this by now but:

White smoke only at higher revs suggest you have a timing problem - I would
first have suspected fuel contamination but changing filters should have
fixed that.

Cheerio,

--
Fishing: http://www.fishing.casterbridge.net/
Writing: http://www.author.casterbridge.net/derek-moody/
uk.rec.fishing.game Badge Page:
http://www.fishing.casterbridge.net/urfg/



Reply
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules

Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Looking for a diesel launch or 24ft or smaller cc diesel Ratliff Logging and Management General 3 October 14th 10 04:38 AM
nanni 4110 HE lawrie gubb Cruising 1 March 19th 07 07:44 PM
Nanni Diesel Engine Problems [email protected] General 10 February 3rd 06 03:41 PM
Which diesel stewart menday General 0 August 18th 03 08:23 AM


All times are GMT +1. The time now is 08:36 AM.

Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2004-2017 BoatBanter.com.
The comments are property of their posters.
 

About Us

"It's about Boats"

 

Copyright © 2017