A Boats forum. BoatBanter.com

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » BoatBanter.com forum » rec.boats » UK Power Boats
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

Nanni Diesel T4 155



 
 
Thread Tools Display Modes
  #1  
Old June 24th 15, 02:38 PM
tugdolan tugdolan is offline
Junior Member
 
First recorded activity by BoatBanter: Jun 2015
Location: Boldon Colliery UK
Posts: 2
Default Nanni Diesel T4 155

Hi all, I have a motor boat that has a Nanni t4 155 hp engine, the problem is When engine is running up to 2000 RPM every thing appears to be ok, on increasing revs the engine starts to miss and power falls off until I bring it back down to 2000 rpm, I have tested the engine along side with GB clutched out, on raising the rpm the engine starts to miss with a lot of white smoke coming from exhaust.
The fuel filters and injectors have been changed, pipe work checked for tightness, all appears ok.
I have tried the engine for a short time with sea suction closed so that no water passes through charge air cooler, When this is tried the white smoke disappears and engine runs smoothly. Open sea cock and after a short while white smoke returns and engine starts missing.
I realise that I can only run engine a short time without cooling as this will do the jabsco no good
Anyone out there had this problem before

Best Regards
Mick
Ads
  #2  
Old July 15th 16, 12:16 AM posted to uk.rec.boats.power
Derek Moody
external usenet poster
 
Posts: 10
Default Nanni Diesel T4 155

In article , tugdolan
wrote:

Hope some one can help, my Nanni diesel engine when started appears ok
and on running up to 2000 RPM is still ok, however above 2000 rpm the
engine starts to emit white smoke and lose power, filters and injectors
have been renewed.


The date of your post sugests either your machine's clock is out or this
post has been held up for a long time so you may have fixed this by now but:

White smoke only at higher revs suggest you have a timing problem - I would
first have suspected fuel contamination but changing filters should have
fixed that.

Cheerio,

--
Fishing: http://www.fishing.casterbridge.net/
Writing: http://www.author.casterbridge.net/derek-moody/
uk.rec.fishing.game Badge Page:
http://www.fishing.casterbridge.net/urfg/

 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Nanni Diesel T4 155 tugdolan UK Power Boats 0 June 24th 15 01:59 PM
Looking for a diesel launch or 24ft or smaller cc diesel Ratliff Logging and Management General 3 October 14th 10 04:38 AM
nanni 4110 HE lawrie gubb Cruising 1 March 19th 07 07:44 PM
Nanni Diesel Engine Problems [email protected] General 10 February 3rd 06 03:41 PM
Which diesel stewart menday General 0 August 18th 03 08:23 AM


All times are GMT +1. The time now is 05:28 AM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2004-2017 BoatBanter.com.
The comments are property of their posters.
new